Configuraciones

advertencia

ADVERTENCIA LEGAL SOBRE LAS DESCARGAS DE ESTA WEB Y SU INFORMACION

 

ATENCION

cuartodecomunicaciones.com es una web de enlaces comentados, completamente independiente que recopila toda la documentación directa y exclusivamente de la red internet, mediante una cuidada selección del contenido tras buscar de la manera más avanzada y eficiente la información que ofrecemos en nuestra web.
El fin último no es lucrativo, difamatorio, propagandístico ni de ninguna otra naturaleza que no sea la utilidad pública gratuita.
Todo tipo de informacion, material y/o datos, que se encuentren publicados y/o expuestos en www.cuartodecomunicaciones.com han sido creados o facilitados por los titulares de los mismos, o por colaboradores de esta y otras paginas de la misma tematica cuya informacion es compartida entre todos sin animo de lucro y de forma totalmente libre.

 

Desconocemos a la persona física o jurídica que pone en la red los contenidos que buscamos, filtramos y recopilamos para citarlos en nuestra web, por tanto, aunque ponemos especial interés en no violar ningún copyright, si así fuera estaremos encantados de retirar dicho material o bien citar y acreditar debidamente al autor en caso de alcanzar un acuerdo o estar el material sujeto a algún tipo de licencia específica.

No aceptaremos reclamaciones de cualquier naturaleza por cese de beneficio o daños de imagen, pérdidas materiales ni de ningún tipo, al no obtener beneficio de ningún tipo por nuestra parte y no ser responsables en origen de la puesta online del material que encontramos en los buscadores públicos, y que está aquí citado y linkado. Nuestra labor es únicamente buscar, citar, linkar y comentar los contenidos que circulan por la red, para lo cual nos amparamos en el derecho de la libertad de expresión.

No podemos en ninguna manera hacernos responsables de los comentarios que los navegantes de esta web pudieran vertir en ellos mismos. Como foro público de discusión y en virtud de la libertad de expresión no se moderarán ni se eliminarán opiniones a favor o en contra de un sistema, equipo, compañía, servicio, marca, o modelo, siempre que no excedan los siguientes límites:

No se tolerarán y serán eliminados aquellos de naturaleza racista, discriminatoria, injuriosa o cualquier tipo de comportamiento alejado del respeto y tolerancia básicos así como las apropiadas normas de convivencia.

No se tolerarán aquellos comentarios que tengan un fin comercial, autopropagandístico, sugieran o intrínsecamente tengan algún animo comercial de favorecimiento o desfavorecimiento tanto propio como ajeno.

Nos reservamos el derecho por respeto a la lengua en la que nos expresamos, a borrar todos aquellos comentarios que contengan un número excesivo de errores, entediendo como tales aquellos que está redactados de manera totalmente despectiva e irrespetuosa con la mínima ortografía básica. De igual manera aceptamos de buen grado las correciones que debamos hacer en nuestros propios textos y que se pueden dirigir a la sección de contacto enviandonos un email.

Open Panel
Configuraciones

Configuraciones (12)

Jueves, 15 Diciembre 2016 19:12

Configuración del Cisco 827 con ADSL de telefónica

Escrito por

Configuración del Cisco 827 con ADSL de telefónica

no service pad
service password-encryption
!
hostname (nombre del router)

enable secret (password del enable)
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Ethernet0
ip address (IP de la red) (mascara de la red)
ip nat inside
no ip mroute-cache
no cdp enable 
interface ATM0
no ip address
no ip route-cache
no ip mroute-cache
no atm auto-configuration
no atm ilmi-keepalive
no atm address-registration
no atm ilmi-enable
bundle-enable
dsl operating-mode auto
hold-queue 208 in
!
interface ATM0.1 point-to-point
ip address (ip que te da el proveedor) (mascara)
ip nat outside
no ip route-cache
no ip mroute-cache
pvc 8/32
encapsulation aal5snap
!
!
ip nat inside source list 101 interface ATM0.1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 ATM0.1
no ip http server 
access-list 101 permit ip any any
!
line con 0
transport input none
stopbits 1
line vty 0 4
password 7 (Password para el telnet)
login
!

Jueves, 15 Diciembre 2016 19:11

Cómo Actualizar la IOS en el Cisco 827

Escrito por

Cómo Actualizar la IOS en el Cisco 827

 

Para Actualizarle la IOS a un router Cisco, necestareis tener un programa Cliente TFTP

como el Cisco TFTP Server instalado en el ordenador. Una vez hecho esto, abrimos en

el ordenador el programa Cisco TFTP Server; lo configuramos para que en la opción

 

TFTP Server root Directory=(Directorio donde está el archivo Flash).

 


Una vez configurado el programa Cisco TFTP Server, accedemos al router mediante

telnet o hyperterminal:

 

Para TELNET: --> Inicio --> Ejecutar --> Telnet (IP Privada del Router)
Conectar el Router al Ordenador con un cable de red

(Necesario para transferir la FLASH mediante el TFTP)

 


Para HYPERTERMINAL: --> Inicio --> Programas --Accesorios --> Hyperterminal
Conectar el Router al Ordenador con un cable de red

(Necesario para transferir la FLASH mediante el TFTP)
Conectarse al Router con el Hyperterminal usando esta configuración:

 

- Protocol: Serial
- Port: Com1
- Baud Rates: 9600
- Data Bits: 8
- Parity: None
- Stop Bits: 1
- Flow Control: None

 


Es recomendable siempre hacer una copia de seguridad de la IOS que tenemos en el Router

ya que sabemos a ciencia cierta que esta nos funciona. Recordemos que un Router Cisco es

ampliable en cuestion de memoria, y que no todas las IOS que nos encontremos para este Router

nos van a servir, ya que en muchos casos no dispondremos de recursos suficientes en el Router

para iniciarlas. A continuacion describo los pasos a seguir para guardar la IOS del Router a un archivo:

 

Teniendo el Cisco TFTP Server abierto y configurado, indicando el directorio donde queremos guardar la IOS,

y la consola del Router abierta, escribimos en consola:

 

Router> enable
Router# copy flash tftp
Source Filename []? (nombre del archivo IOS)
Address or name of remote host []? (IP del Router)
Destination Filename []? (nombre del archivo IOS)
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!
3802992 bytes copied in 27.276 secs (140851 bytes/sec)

 


Teniendo el Cisco TFTP Server abierto y configurado, indicando el directorio donde se encuentra la nueva IOS, y la consola del Router abierta, escribimos en consola:

 

Router> enable
Router# copy tftp flash
Address or name of remote host []? (IP del ordenador que tiene el TFTP)
Source Filename []? (nombre del archivo IOS)
Destination Filename []? (nombre del archivo IOS)
Warning:There is a file already existing with this name
Do you want to over write? [confirm]
Accessing tftp://xxx.xxx.xxx.xxx/c827v-y6-mz.121-1.XB...
Erase flash: before copying? [confirm]
Erasing the flash filesystem will remove all files! Continue? [confirm]
Erasing device... eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
ee ...erased
Erase of flash: complete
Loading c827v-y6-mz.121-1.XB from 10.1.1.1 (via Ethernet0): !!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!
[OK - 3802992/7605248 bytes]

 

Verifying checksum... OK (0x1ABC)
3802992 bytes copied in 58.236 secs (65568 bytes/sec)
Router#

 

Una vez llegados a este punto reiniciamos el Router para cargar la nueva IOS:

 

Router# reload

 

Una vez reiniciado el Router, podemos comprobar la version instalada con el siguiente comando:

 

Router> show version

 

Y listo, tenemos nuestro Router Actualizado. Si por algún motivo nos diera error al reiniciar el Router, y no se cargase la configuración, tendríamos realizar los pasos indicados en la seccion siguiente, utilizando la IOS anterior.

 


==========================

 


Instalar el Servidor tftp en un ordenador.
Instalar el CTR (Emulador de HyperTerminal).
Conectar el Router al Ordenador con un cable de red (Necesario para transferir la FLASH mediante el TFTP)
Conectarse al Router con el CTR a traves de serial usando esta configuración:

 

- Protocol: Serial
- Port: Com1
- Baud Rates: 9600
- Data Bits: 8
- Parity: None
- Stop Bits: 1
- Flow Control: None

 

Una vez dentro, si tenemos que detener la carga de la flash, ejecutamos la combinación de teclas [Control] + [Pause] en los primeros segundos, para entrar en modo:

 

Rommon 1>

 

En este modo tecleamos en pantalla

 

Rommon 1>tftpdnld [Enter]

 

Aparecerán las siguientes líneas:

 

----------------------------------------------------------------------------------

 

Missing or illegal ip address for variable IP_ADDRESS
Illegal IP address.

 

usage: tftpdnld [-ur]
Use this command for disaster recovery only to recover an image via TFTP.
Monitor variables are used to set up parameters for the transfer.
(Syntax: "VARIABLE_NAME=value" and use "set" to show current variables.)
"ctrl-c" or "break" stops the transfer before flash erase begins.

 

The following variables are REQUIRED to be set for tftpdnld:
IP_ADDRESS: The IP address for this unit
IP_SUBNET_MASK: The subnet mask for this unit
DEFAULT_GATEWAY: The default gateway for this unit
TFTP_SERVER: The IP address of the server to fetch from
TFTP_FILE: The filename to fetch

 

The following variables are OPTIONAL:
TFTP_VERBOSE: Print setting. 0=quiet, 1=progress(default), 2=verbose
TFTP_RETRY_COUNT: Retry count for ARP and TFTP (default=7)
TFTP_TIMEOUT: Overall timeout of operation in seconds (default=7200)
TFTP_CHECKSUM: Perform checksum test on image, 0=no, 1=yes (default=1)

 

Command line options:
-r: do not write flash, load to DRAM only and launch image
-u: upgrade the rommon, system will reboot once upgrade is complete

 

----------------------------------------------------------------------------------

 


Para hacer posible la descarga del archivo al Router, tendremos que introducir los comandos de la lista sustituyendo los datos por los pertenecientes a nuestro sistema:

 

IP_ADDRESS=(La IP del Router)
IP_SUBNET_MASK=(La Máscara de Subred de la Red)
DEFAULT_GATEWAY=(La IP del Router)
TFTP_SERVER=(La IP del ordenador que contiene el archivo)
TFTP_FILE=(El Nombre del Archivo que queremos flashear al Router)

 

Una vez hecho esto, abrimos en el ordenador el programa Cisco TFTP Server; lo configuramos para que en la opción

 

TFTP Server root Directory=(Directorio donde está el archivo Flash).

 

Una vez hecho todo esto, escribimos en la consola del CRT:

 

Rommon 10>tftdnld [Enter]

 

Aceptamos las opciones que nos vayan apareciendo, y listo; el Router queda programado con la nueva Flash. Solo hay que reiniciarlo y listo.



Jueves, 15 Diciembre 2016 19:10

Recuperación de la IOS del router Cisco 827

Escrito por

Recuperación de la IOS del router Cisco 827

 

Este manual es fruto de la experiencia que he tenido mientras configuraba un router Cisco 827, ya que durante la operación de configuración borré accidentalmente la IOS o firmware. Y debo añadir que no soy informático, sólo un aficionado, así que pido disculpas de antemano por las inexactitudes que se puedan encontrar en este documento.

 

Una vez borrada la IOS del router, este pasa a funcionar con lo que se llama la memoria Rom que tiene incorporada y con la cual puede ejecutar algunas instrucciones, pero no puede ejercer su función de Router.

 

Por tanto tendremos que volver a incorporar en la memoria Flash la citada IOS para que el router vuelva a funcionar.

 

Primero debemos conseguir el archivo IOS del router, este suele ser un fichero de entre 3 y 6 Mb dependiendo de la versión del mismo, según el tipo de router que tengamos. El archivo se suele llamar algo así como c827v-y6-mz.121-1.XB, este nombre puede variar según la versión del firmware de la que se trate, así que este nombre lo incluyo en el presente documento a modo de ejemplo.

 

Bien una vez dispongamos del firmware o IOS para el router debemos grabarlo en la memoria flash, para que este vuelva a funcionar, esto se puede hacer de dos maneras, una que es lenta, y la que yo utilicé, a través del Hyperterminal de Windows o bien a través de Tftp, esta última forma es mucho más rápida, ya que funciona a través de la red, pero para la cual deberemos tener instalado un servidor TFTP en nuestro ordenador y configurarlo. Se puede conseguir el programa para crear nuestro servidor Tftp gratuitamente en Internet, aunque su configuración y funcionamiento pertenece a otro manual.

 

Por tanto en el presente manual hablaremos del método que yo utilice para introducir la IOS del router.

 

Bien una vez tengamos el archivo de la IOS que necesitamos para nuestro modelo de router, lo guardamos en el ordenador al cual vamos a conectar a través del cable azul con nuestro router.

 

El cable azul mencionado es el que viene de fábrica con nuestro router, tiene dos salidas una que es una RJ45 de red normal, que se enchufa al router (salida azul), y la otra es una serial que enchufaremos a un puerto de serie del ordenador.

 

La siguiente opción es configurar el Hyperterminal de Windows para que se pueda comunicar nuestro ordenador con el router.

 

Vamos a Inicio de Windows, seleccionamos programas, accesorios, comunicaciones, Hyperterminal (en caso de que no lo tengamos instalado, tendremos que instalarlo a través del panel de configuración de Windows, seleccionando la opción de Agregar Quitar programas, instalación de Windows).

 

Seleccionado el Hyperterminal se abrirá una pantalla que nos pedirá un nombre para la conexión, le llamamos como queramos, en este caso prueba, y se abre la ventana que podemos ver en la página siguiente:

 

 
1-Ventana de configuración del puerto COM1

 

La ventana que vemos es la de configuración de características del puerto de comunicaciones COM1, puesto que normalmente sólo hay dos puertos de serie en los ordenadores, existen dos opciones el COM1 ó el COM2, yo como no tenía nada conectado elegí el 1, va en función de las preferencias del usuario o de sus necesidades según el caso.

 

Las opciones correspondientes deben de estar tal y como se presentan en la anterior ventana, es decir:

 

 

Bits por segundo: 9.600
Bits de datos:  8
Paridad:  Ninguno
Bits de parada: 1
Control de flujo: Ninguno

 

Esta es la configuración de nuestro puerto COM1 para conseguir una correcta comunicación entre nuestro ordenador y el router.

 

Pinchamos sobre Aceptar y entonces se nos abre la pantalla que aparece en la página siguiente:

 

 
2-Ventana del Hyperterminal

 

En esta pantalla aparecerá la expresión:

 

rommon >

 

Esto nos indica que el router está funcionando con su ROM básica, se pueden ejecutar algunas órdenes, en este caso introduciremos el comando de subida-grabación en la Flash de la IOS. El comando que debemos introducir es "xmodem".

 

Introduciremos el comando de esta manera:

 

rommon >xmodem c827v-y6-mz.121-1.XB

 

Debemos tener en cuenta que el nombre del archivo se introduce para que el router grabe en su flash el archivo con el nombre que le especificamos, ya que es incapaz de encontrar el archivo en nuestro ordenador.

 

Debemos esperar a que nos aparezca el mensaje:

 

Ready to recibe file c827v-y6-mz.121-1.XB

 

Bien ahora el router está preparado para recibir el archivo, como el no lo puede buscar y cargarlo automáticamente, debemos subirlo nosotros al router a través del Hyperterminal. Para ello nos vamos a la ventana anteriormente presentada y en los botones superiores seleccionamos el que nos indica la leyenda "enviar", al pinchar se abrirá la pantalla que vemos a continuación:

 

 
3-Ventana de selección del archivo a enviar.

 

En esta ventana que se abre seleccionaremos el archivo de la IOS del router que tenemos en nuestro ordenador, a través del botón Examinar…

 

Una vez elegido el archivo, debemos seleccionar en el desplegable de abajo el protocolo de transmisión del archivo, en este caso el Xmodem, que es el que le hemos indicado al router que vamos a utilizar.

 

Una vez realizado todo lo anterior le damos a Aceptar, y comenzará la transmisión del archivo, se abre una ventana de estadísticas, que no reproduzco, en la que nos indica el estado de la transmisión del archivo.

 

Debemos tener en cuenta que a 9600 baudios, el proceso de subida dura cerca de una hora para un archivo de 3 Mb, según cisco se puede incrementar la velocidad de transmisión, pero yo no lo he probado.

 

Una vez completada la transmisión, el router reconoce el archivo, lo descomprime y se pone a funcionar.

 

Ahora nos queda comprobar la versión de nuestra IOS. Atención esto es fundamental para que cuando apaguemos nuestro router este vuelva a arrancar con la IOS, puesto que si no reconoce la versión arrancará otra vez con el rommon.

 

Esto se hace con el comando "show version", comprobaremos que la versión es la 0x2102, en caso de que no tengamos esta versión debemos modificarla, esto se hace así:

 

Router#configure terminal
Router (config)#config-reg 0x2102
Router (config)#exit
Router#reload

 

Y ya tendremos la configuración cambiada y con la versión adecuada para que el router funcione correctamente.

 

Ahora ya sólo queda configurarlo para que funcione con nuestra conexión ADSL.


Jueves, 15 Diciembre 2016 19:09

Netmeeting con router Cisco

Escrito por

Netmeeting con router Cisco

Primeramente conectarse por terminal al router. Por telnet o por conexión serie.

Trabajaremos mapeando por NAT los siguientes puertos:
TCP 1503
TCP 522
TCP 389
TCP 1720
TCP 1731

A continuación realizaremos la misma operación para cada puerto. 

enable
conf term
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp [IP_Interna] 1503 [IP_Externa]
1503 extendable

Toda esta información se incluye en 1 sola línea. 

A continuación repetir la misma operación para el siguiente puerto.

Nota: Dialer0 o cualquier otro nombre hará referencia al nombre de interfaz de red del router sobre el que se está haciendo NAT.

ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp [IP_Interna] 522 [IP_Externa]
522 extendable


....
....
Una vez finalizado el proceso con todos los puertos, pulsar enter para crear una línea en blanco y acto seguido CTRL+Z, para indicar que la configuración ha terminado.

Despues escribir 'wr' para que estos cambios queden grabados en la NV RAM del router.

Jueves, 15 Diciembre 2016 19:09

Configuración MONOPUESTO en un router Cisco827

Escrito por

Configuración MONOPUESTO en un router Cisco827

Despues de muchas pruebas y horas invertidas he conseguido configurar mi router Cisco 827 en modo monopuesto de forma que el PC tenga la IP pública y así no tener que usar el NAT para navegar por internet.

Esto le será útil a la gente que sólo disponga de un PC en su red y quiera usar netmeeting, IPSec, VPN, etc sin tener que hacer auténticas virguerías o para los que como yo dispongamos de un servidor con linux y con el IPTABLES haciendo de firewall y de router para la red local.



Esta configuración está pensada para ser usada con las ADSL de telefónica, para otros proveedores se tendrá que adaptar...

La configuración es en sí tremendamente sencilla, simplemente cambiad la XXX.XXX.XXX.XXX por la dirección de vuestro gateway de telefónica ([IP Pública] AND [Máscara de RED] + 1 normalmente) y el 255.255.255.MMM por vuestra máscara.

Ahora simplemente deberéis configurar vuestro PC con la IP y Máscara de la dirección pública y poner como Puerta de enlace predeterminada la XXX.XXX.XXX.XXX.

Si lo deseamos siempre podemos activar el servidor DHCP de la forma tradicional para que el PC obtenga las IPs de forma automática, yo no lo he puesto porque no lo necesitaba.

Y ahora el startup-config, los usuarios y password que encontréis los deberéis cambiar claro está:

version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco827
!
logging rate-limit console 10 except errors
enable secret 5 [PASSWORD]
!
username [USUARIO] password 7 [PASSWORD]
ip subnet-zero
!
interface Ethernet0
 ip address XXX.XXX.XXX.XXX 255.255.255.MMM
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 hold-queue 224 in
!
interface ATM0.1 point-to-point
 bandwidth 256
 ip address 10.0.0.1 255.0.0.0
 pvc 8/32
  protocol ip inarp
  encapsulation aal5snap
 !
!
ip classless
ip route 0.0.0.0 0.0.0.0 ATM0.1
no ip http server
!
line con 0
 exec-timeout 120 0
 stopbits 1
line vty 0 4
 access-class 23 in
 exec-timeout 120 0
 login local
 length 0
!
end

Jueves, 15 Diciembre 2016 19:08

Conectando por Hyperterminal

Escrito por

Conectando por Hyperterminal

Proceso para la conexión por Hyperterminal a los routers Cisco 827 o genéricos de Cisco.

Configuración a través de CLI

Paso 1. Conecta el cable DB9-RJ45, el conector DB9 a cualquier puerto serie COM del ordenador y el RJ45 al puerto de Consola del router.

Paso 2. Inicia una sesión de Hyperterminal hacia el router con los siguientes valores por defecto

Bits per second 9600
Data bits 8
Parity None
Stop bits 1
Flow control Default

Paso 3. Enciende el router. Si los ajustes son correctos deberías ver algunas palabras aparecer.

Paso 4. Si ves el siguiente prompt introduce 'No' y pulsa enter, si no continua al siguiente paso

Would you like to enter the initial configuration dialog? [yes/no]: no

Paso 5. Espera hasta ver el siguiente prompt y pulsa Enter

Press RETURN to get started!

Paso 6. Deberías ver el siguiente indicador ahora. Utiliza el comando 'enable' y pulsa enter

Router>enable

Paso 7. Una vez aquí puedes proceder con los siguientes comandos para realizar la configuración de la IP del router.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface ethernet 0
router(config)#ip http server
Router(config-if)#ip address 10.10.10.1 255.255.255.0

Paso 8. Continua con las configuraciones propuestas en los otros artículos de la sección del router Cisco 827.

Jueves, 15 Diciembre 2016 19:07

Port Forwarding y DMZ detrás de NAT

Escrito por

Port Forwarding y DMZ detrás de NAT

Comandos para la configuración del IP Forwarding y ajuste de la DMZ en Cisco 827, o genérico para routers Cisco con IOS 12.2x.Configuración para Port Forwarding y DMZ detrás de NAT

Paso 1. Conectar al router a través de Hyperterminal. Puedes leer el artículo que especifica cómo conectar por hyperterminal en esta sección de Cisco 827.

Paso 2. Continuar con los siguientes comandos

Para IP estática

router(config)#ip nat inside source static

Para IP dinámica, puedes utilizar el parámetro interface de WAN, si utilizas una versión de IOS 12.2x.

router(config)#ip nat inside source static

Si no utilizas IOS 12.2x, entonces debes conocer la IP de WAN. Puedes utilizar el siguiente comando

router#show int

Dialer0 is up, line protocol is up (spoofing)
Hardware is Unknown
Internet address is 210.193.14.26/32

Jueves, 15 Diciembre 2016 19:06

Configuración PPPoE con CLI

Escrito por
Configuración PPPoE con CLI
A continuación os mostramos un interesante documento que contiene una plantilla para la configuración PPPoE con el router Cisco ADSL 827, así como unos interesantes enlaces para poder hacer funcionar este sistema correctamente, donde Microsoft y Cisco, especifican el por qué de la necesidad de cambiar el MTU en todos los PC's, porque a veces hay páginas que no funcionan o no se pueden ver.

Sigue leyendo ...
 
Configuración PPPoE con NAT

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#no ip http server
Router(config)#vpdn enable
Router(config)#vpdn-group ppoe
Router(config-vpdn)#request-dialin
Router(config-vpdn-req-in)#protocol pppoe
Router(config-vpdn-req-in)#exit
Router(config-vpdn)#exit
Router(config)#interface ethernet0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface atm0
Router(config-if)#pvc <VPI/VCI>
Router(config-if)#no shutdown
Router(config-if-atm-vc)#pppoe-client dial-pool-number 1
Router(config-if-atm-vc)#exit
Router(config-if)#exit
Router(config)#int dialer 1

Si tienes ip estática asignada por tu proveedor utiliza este comando
Router(config-if)#ip address <WAN IP> <WAN subnet mask>

Si utilizas IP dinámica usa este comando
Router(config-if)#ip address negotiated

Continue with the rest of command
Router(config-if)#ip mtu 1492
Router(config-if)#ip nat outside
Router(config-if)#dialer pool 1
Router(config-if)#ppp authentication pap callin
Router(config-if)#ppp pap sent-username <username> password <password>
Router(config-if)#exit
Router(config)#ip nat inside source list 1 interface dialer 1 overload
Router(config)#ip classless

Si tienes ip estática asignada por tu proveedor utiliza este comando
Router(config)#ip route 0.0.0.0 0.0.0.0 <WAN gateway>

Si utilizas IP dinámica usa este comando
Router(config)#ip route 0.0.0.0 0.0.0.0 dialer 1

Continua con el resto de comandos
Router(config)#no ip http server
Router(config)#access-list 1 permit 10.10.10.1 0.0.0.255
Router(config)#exit
Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Router#

Paso 2. Ajusta el MTU de todos los PC's a 1492. El how-to para saber cómo hacer y por qué podeis encontrarlo en estas páginas de Cisco y Microsoft.

Troubleshooting MTU Size in PPPoE Dial in Connectivity

PPPoE with ICS Requires MTU Setting Below 1492 on the ICS Clients

Jueves, 15 Diciembre 2016 19:05

Programacion PPPoA con CLI

Escrito por
Programacion PPPoA con CLI
A continuación os proponemos una plantilla de configuración para sistemas basados en conexiones PPPoA con el router Cisco ADSL 827.

Sigue leyendo...
 

Configuración PPPoA con NAT

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface ethernet 0
router(config)#no ip http server
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface dialer 0

Si tienes la IP asignada de forma estática por tu ISP,entonces utiliza este comando
Router(config-if)#ip address <WAN IP> <WAN subnet mask>

Si tienes la IP asignada de forma dinámica por tu IPS, entonces utiliza este comando 
Router(config-if)#ip address negotiated

Continuar con el resto de comandos
Router(config-if)#ip nat outside
Router(config-if)#encapsulation ppp
Router(config-if)#dialer pool 1
Router(config-if)#ppp pap sent-username <username> password <password>
Router(config-if)#exit
Router(config)#interface atm 0
Router(config-if)#pvc <VPI/VCI>
Router(config-if-atm-vc)#en aal5mux ppp dialer
Router(config-if-atm-vc)#dialer pool-member 1
Router(config-if-atm-vc)#no shutdown
Router(config-if)#exit
Router(config)#ip nat inside source list 1 interface dialer 0 overload

Si tienes IP estática utiliza este comando
Router(config)#ip route 0.0.0.0 0.0.0.0 <WAN gateway>

Si tienes IP dinámica utiliza este comando
Router(config)#ip route 0.0.0.0 0.0.0.0 dialer 0

Continuar con el resto de comandos 
Router(config)#access-list 1 permit 10.10.10.0 0.0.0.255
Router(config)#exit
 
Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Router#

Jueves, 15 Diciembre 2016 19:04

Desbloqueo Router Cisco

Escrito por

Desbloqueo Router Cisco

1.Entrando por consola reiniciar el router y en los primeros segundos antes de que cargue el archivo de configuración mandarle un "break" para que no cargue el software y arranque desde la ROM. Esto a mí me costó bastante pues ninguna de las combinaciones de teclas de windows (ctrl-c, etc.) surtía efecto. En el sitio de cisco en la web encontré que cuando todo esto falla hay que crear una nueva conexión de consola para el break a una velocidad de 1200 y oprimir la tecla espaciadora durante 15 segundos. Después, para la configuración, hay que volver a conectarse a la habitual de 9600. Funcionó, y también funciona desde un macintosh con la orden break del menú del programa Zterm (Insistiendo un poco). 

2.Una vez que el break ha funcionado el router arranca desde la rom y nos lo demuestra con el prompt "rommon 1>", desde aquí podemos abrir el fichero de configuración y modificarlo a nuestro antojo. Lo que todavía no he podido averiguar es cómo  saber el nombre de usuario y contraseña para la conexión ppp con el proveedor de servicios, pues al igual que el resto de las contraseñas estaban escriptadas, las del router se pueden cambiar por otras pero las de la conexión no :(. Esto no es un problema pues estos dos datos no los cambié en el archivo y siguen ahí funcionando pero me gustaría saberlo por curiosidad. 

Está aquí:

Acceso

La opción de clave secreta es sólo para los que tienen activada la verificación en dos pasos (Ej:Google)
 
 
     
Olvido el nombre de usuario?   Registrarse  

Registro y Acceso